# Table of Contents

1. Introduction .............................................................................................................................................. 4
2. Loading Data............................................................................................................................................... 4
   2.1. Opening an SDFile .......................................................................................................................... 4
   2.2. Auto Detection of Structure Column and Content Type.............................................................. 5
3. Exporting Data.......................................................................................................................................... 9
   3.1. Exporting Data to an SDFile........................................................................................................... 9
   3.2. Details on Export to SDFile Dialog ............................................................................................... 9
   3.3. Exporting Data to a ChemDraw for Excel file ............................................................................. 11
   3.4. Details on Export to ChemDraw for Excel Dialog .................................................................... 13
4. Working with Structures......................................................................................................................... 16
   4.1. About the Structure Viewer .......................................................................................................... 16
   4.2. Using the Structure Viewer ......................................................................................................... 18
   4.3. About the Structure Viewer Toolbar ............................................................................................ 19
   4.4. About the Structure Viewer List Content Pane ........................................................................... 19
   4.5. About the Structure Viewer Structure Viewer Pane .................................................................... 21
   4.6. Configuring Structure Connections .............................................................................................. 22
5. Working with ID Lists ............................................................................................................................... 23
   5.1. About ID Lists in the Structure Viewer ......................................................................................... 23
   5.2. About Manage Lists in the Structure Viewer ............................................................................... 25
   5.3. About New Lists Dialog .............................................................................................................. 26
6. Searching Structures ................................................................................................................................ 27
   6.1. Searching for Compounds using Structure Search ....................................................................... 27
   6.2. About the Structure Search Dialog .............................................................................................. 28
   6.3. Viewing Structures in Virtual Columns ......................................................................................... 30
   6.4. Viewing Structures in Labels or Tooltips .................................................................................... 30
7. Structure Filtering .................................................................................................................................... 33
   7.1. About the Structure Filter ............................................................................................................ 33
   7.2. Accessing the Structure Filter ..................................................................................................... 33
   7.3. About the Structure Filter Toolbar ............................................................................................... 34
   7.4. Search Types .................................................................................................................................... 34
7.5. Performing a Structure Filter ........................................................................................................35
6.6. Editing a Filter ..............................................................................................................................40
7.7. Clearing a Filter............................................................................................................................40
8. R-Group Decomposition ..................................................................................................................41
9. Settings ............................................................................................................................................44
  9.1. Supported Renderers.....................................................................................................................44
  9.2. Renderer Settings..........................................................................................................................46
10. Glossary ..........................................................................................................................................49
1. Introduction

This Guide provides a description of the chemical structure display and search functionality available in Lead Discovery. With Lead Discovery, you can:

- Open an SDFile and view its fields in the table visualization, including the molecular structures.
- View SMILES strings as chemical structures in a table visualization or the Structure Viewer.
- Load chemical structures from a database in molfile, smiles or ChemDraw formats.
- Export data to an SDFile.
- Export data directly to a ChemDraw for Excel file format, preserving the structure data.
- Use the Structure Viewer to view chemical structures, and to create, export, and import ID lists.
- Search on structures in a database using similarity and substructure search.
- Highlight the query molecule within a structure search hit using CScartridge.
- Set a ChemDraw template (.cds) to be used for visualizing structures.
- Filter the contents of a data table based on structure.
- Perform an R-Group decomposition analysis on the results of a substructure filter.

2. Loading Data

2.1. Opening an SDFile

You can open an SDFile to view in the table visualization.

To open an SDFile:

1. Click on Open on the toolbar, or select File > Open from the File menu.
2. Browse to the SDFile you want to open and click Open. An initial visualization using the fields of the SDFile appears.
3. If your initial visualization is not a table, create a new Table visualization. The table containing the fields of the SDFile, including the chemical structures appears.

As with any table visualization, you can:

- Save this analysis to file or library (see the "Saving an Analysis file in the Library" topic of the Spotfire online help).
- Change the column order, column width, or row height; add, remove, sort, or mark rows (see the "How to Use the Table" topic of the Spotfire online help).
- Change the table appearance and settings using the Table Properties Dialog.

You can export the contents of table visualization to an SDFile or a ChemDraw for Excel file.

Tip: When viewing data containing structures, you can change the default row height in the table visualization by selecting Tools > Options and go to the Table page. There, change the Data row height to a suitable number. You can also change the default initial visualization to be a table by going to the Document page, and changing the Initial visualization when loading data to Table.
2.2. Auto Detection of Structure Column and Content Type

Structure column(s) and the content type for each structure column are automatically detected when data is imported into Spotfire.

If the content type is mistakenly identified, you can change the content type through the Column Properties for a data table. Additionally if a structure column was not identified as such, you can set the content type through the Column Properties.

To identify the content type for a column:

1. Select **Edit > Column Properties** from the Edit menu.

2. Select the column for which you want to specify the content type. If there is more than one table, you may have to choose the table first.

3. Select the **Properties** tab. Select the Content Type property.
4. Click on the **Edit** button to open the Edit Property dialog.
5. Edit the value to reflect the correct content type.

**Note:** The content type you enter can be an arbitrary string, but it is recommended that you use the MIME types defined for molfiles, CHIME, SMILES and CDX strings as shown in the table below.

<table>
<thead>
<tr>
<th>Structure Format</th>
<th>Content Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>MDL molfile</td>
<td>chemical/x-mdl-molfile</td>
</tr>
<tr>
<td>MDL Chime string</td>
<td>chemical/x-mdl-chime</td>
</tr>
<tr>
<td>Daylight SMILES string</td>
<td>chemical/x-daylight-smiles</td>
</tr>
<tr>
<td>ChemDraw Chemical Structure Exchange</td>
<td>chemical/x-cdx</td>
</tr>
</tbody>
</table>

6. Click ‘OK’ to return to the **Column Properties** dialog. The value field is updated with the content type.
7. Click ‘OK’.

Note: Chemical structures loaded into Spotfire in ChemDraw’s native file format (CDX, CDMXL) are supported for chemical rendering, chemical searching and exporting. This content in data tables will be displayed natively in renderers that support the format (ChemDraw) or converted to MOLfiles or SMILES for renderers that do not offer support. Query molecules will be extracted from renderers that support the format (ChemDraw) and sent unchanged to cartridges that support the format or converted to MOLfiles or SMILES for cartridges that do not.
3. Exporting Data

You can export data from Lead Discovery to an SDFile or to a ChemDraw for Excel file.

3.1. Exporting Data to an SDFile

To export data from visualization table to an SDFile:

1. Right-click on the table and select **Export to SDFile**.
2. Select whether to export all rows, marked rows, or filtered rows only:
   - **All rows** - Exports every row in the data table regardless of filtering.
   - **Marked rows** - Exports the marked rows of the table only.
   - **Filtered rows** - Exports the rows remaining after filtering only.
3. Select the **Structure column** from the drop-down list.
   - **Comment**: The SDFile format supports only one structure per record. You can select any column in the table that contains Molfile or SMILES structures. The first column containing structures displays as the default choice.
4. Use **Add >**, **< Remove**, and **Remove All** to select the columns to export with the structure.
5. Use **Move Up** and **Move Down** to specify the order of columns in the SDFile.
6. Click **OK**.
7. In the **Save As** dialog, specify a filename, browse to the location where you want to save the file.
8. Click **Save**.

**Tip**: You can export data to an SDFile by selecting **File > Export > Data** from the main menu and choosing Save as type: SDFile (*.sd;*.sdf). However, you will not be able to change the columns to include in the export if you use this method.

To export data from the Structure Viewer to an SDFile:

1. Select the IDs you want to export in the List Content pane of the Structure Viewer panel or popover.
2. Right-click on any of the selected IDs and select **Export Selection to SDFile**.
3. Select the **Structure column** from the drop-down list.

   - **Comment**: The SDFile format supports only one structure per record. You can select any column in the table that contains Molfile or SMILES structures. The first column containing structures is displayed as the default choice.
4. Use **Add >**, **< Remove**, and **Remove All** to select the columns to be exported with the structure.
5. Use **Move Up** and **Move Down** to specify the order of columns in the SDFile.
6. Click **OK**.
7. In the **Save As** dialog, specify a filename, browse to the location where you want to save the file.
8. Click **Save**.

3.2. Details on Export to SDFile Dialog

To navigate to the Export to SDFile dialog:

1. Right-click on the table and select **Export to SDFile**.
Comment: If the table does not contain any structures, the Export to SDFile menu item will be unavailable.

OR

2. Select the IDs you want to export in the List Content pane of the Structure Viewer panel or popover.
3. Right-click on any of the selected IDs and select Export Selection to SDFile.

The following table explains the fields displayed in the Export to SDFile window, as shown above.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export</td>
<td><strong>Note:</strong> If you exported data from the Structure Viewer, these options will not be available since you have already selected which rows to export.</td>
</tr>
<tr>
<td>All rows</td>
<td>Exports all rows in the selected data table.</td>
</tr>
<tr>
<td>Marked rows</td>
<td>Exports data for the marked rows only.</td>
</tr>
<tr>
<td>Filtered rows</td>
<td>Exports data for the filtered rows only.</td>
</tr>
<tr>
<td>Structure column</td>
<td>Specify the column in the data table that contains molecular structures.</td>
</tr>
</tbody>
</table>
Displays the available structure columns. Select the one you wish to export. If no structure column is available in the actual data set (for example, if structures are shown in a virtual column) you will not be able to export the structures using this tool.

### Available columns
Lists the columns of the data table that are currently not selected for exporting to the SDFile.

### Columns to include in SDFile
Lists the columns of the table that are currently selected for exporting to the SDFile.

### Add >
Adds the selected column to the list of columns to include in the SDFile.

### < Remove
Removes the selected column from the list of columns to include in the SDFile and returns it to the list of available columns.

### Remove All
Removes all columns from the list of columns to include in the SDFile and returns them to the list of available columns.

### Move Up
Moves the selected items in the Columns to include in SDFile list up one step. The order of the columns in this list determines the order of the columns in the resulting SDFile.

### Move Down
Moves the selected items in the Columns to include in SDFile list down one step. The order of the columns in this list determines the order of the columns in the resulting SDFile.

## 3.3. Exporting Data to a ChemDraw for Excel file

**Note:** The Export to ChemDraw for Excel menu item is available on all clients, regardless of the presence of ChemDraw for Excel. Lead Discovery does not need ChemDraw for Excel present in order to produce an Excel file.
file that is compatible with ChemDraw for Excel. The user will need the ChemDraw/Excel Add-In to open the file, but not to export it.

The file produced by Lead Discovery is saved in Excel's *.xlsx format.

The file that can be opened by Excel, regardless of whether it is equipped with the ChemDrawExcel Add-In. However, the chemical structures will only be converted into pictures when the ChemDrawExcel Add-In is present.

After successfully opening in Excel, the file, if re-saved, will contain the chemical structure pictures. It will display structure systems in Excel (without ChemDrawExcel Add-In); however, the structures will not be searchable or editable in Excel.

**Note:** Chemical structures loaded into Spotfire in ChemDraw's native file format (CDX) can also be exported to ChemDraw for Excel.

**Note:** The File > Export > Data feature in Spotfire is not the same as the Export to ChemDraw for Excel feature. Any results exported into Excel using the native Spotfire export feature may vary depending on how the structure data was imported into Spotfire. It is recommended that you use the Export to ChemDraw for Excel option.

**To export data from visualization table to ChemDraw for Excel file:**

1. Right-click on the table and select Export to ChemDraw for Excel.
2. Select whether to export all rows, marked rows, or filtered rows only:
   - **All rows** - Exports every row in the data table regardless of filtering.
   - **Marked rows** - Exports the marked rows of the table only.
   - **Filtered rows** - Exports the rows remaining after filtering only.
3. Select the **Structure column** from the drop-down list.
   - **Comment:** The Export to ChemDraw for Excel feature supports the export of one structure column per record. You can select any column in the table that contains Molfile, SMILES, and CDX structures. The first column containing structures displays as the default choice.
4. Use **Add >**, < **Remove**, and **Remove All** to select the columns to export with the structure.
5. Use **Move Up** and **Move Down** to specify the order of columns in the ChemDraw for Excel file.
6. Click **OK**.
7. In the **Save As** dialog, specify a filename, browse to the location where you want to save the file.
8. Click **Save**.

**Tip:** You can export data to a ChemDraw Excel File by selecting **File > Export > Data** from the main menu and choosing Save as type: ChemDraw for Excel File (*.xlsx). However, you will not be able to change the columns to include in the export if you use this method.

**To export data from the Structure Viewer to a ChemDraw for Excel File:**

1. Select the IDs you want to export in the List Content pane of the Structure Viewer panel or popover.
2. Right-click on any of the selected IDs and select **Export Selection to ChemDraw for Excel**.
3. Select the **Structure column** from the drop-down list.
   - **Comment:** The ChemDraw Excel File format supports only one structure per record. You can select any column in the table that contains Molfile, SMILES, and CDX structures. The first column containing structures displays as the default choice.
4. Use Add >, < Remove, and Remove All to select the columns to be exported with the structure.
5. Use Move Up and Move Down to specify the order of columns in the ChemDraw Excel File.
6. Click OK.
7. In the Save As dialog, specify a filename, browse to the location where you want to save the file.
8. Click Save.

### 3.4. Details on Export to ChemDraw for Excel Dialog

To navigate to the Export to ChemDraw for Excel dialog:

1. Right-click on the table and select Export to ChemDraw for Excel.
   \*Comment: If the table does not contain any structures, the Export to ChemDraw for Excel menu item will be unavailable.
   \*OR
2. Select the IDs you want to export in the List Content pane of the Structure Viewer panel or popover.
3. Right-click on any of the selected IDs and select Export Selection to ChemDraw for Excel.

![Export to ChemDraw Excel File window](image)

The following table explains the fields displayed in the Export to ChemDraw Excel File window, as shown above.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export</td>
<td>Note: If you exported data from the Structure Viewer, these options will not be available since you have already</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>All rows</td>
<td>Exports all rows in the selected data table.</td>
</tr>
<tr>
<td>Marked rows</td>
<td>Exports data for the marked rows only.</td>
</tr>
<tr>
<td>Filtered rows</td>
<td>Exports data for the filtered rows only.</td>
</tr>
<tr>
<td>Structure column</td>
<td>Specify the column in the data table that contains molecular structures.</td>
</tr>
<tr>
<td></td>
<td>Displays the available structure columns. Select the one you wish to export.</td>
</tr>
<tr>
<td></td>
<td>If no structure column is available in the actual data set (for example, if</td>
</tr>
<tr>
<td></td>
<td>structures are shown in a virtual column) you will not be able to export</td>
</tr>
<tr>
<td></td>
<td>the structures using this tool.</td>
</tr>
<tr>
<td>Available columns</td>
<td>Lists the columns of the data table that are currently not selected for</td>
</tr>
<tr>
<td></td>
<td>exporting to ChemDraw for Excel.</td>
</tr>
<tr>
<td>Columns to include in</td>
<td>Lists the columns of the table that are currently selected for exporting to</td>
</tr>
<tr>
<td>Add &gt;</td>
<td>Adds the selected column to the list of columns to include in the ChemDraw</td>
</tr>
<tr>
<td></td>
<td>Excel File.</td>
</tr>
<tr>
<td>&lt; Remove</td>
<td>Removes the selected column from the list of columns to include in the</td>
</tr>
<tr>
<td></td>
<td>ChemDraw Excel File and returns it to the list of available columns.</td>
</tr>
<tr>
<td>Remove All</td>
<td>Removes all columns from the list of columns to include in the ChemDraw</td>
</tr>
<tr>
<td></td>
<td>Excel File and returns them to the list of available columns.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Moves the selected items in the Columns to include in ChemDraw Excel File</td>
</tr>
<tr>
<td></td>
<td>list up one step. The order of the columns in this list determines the</td>
</tr>
<tr>
<td></td>
<td>order of the columns in</td>
</tr>
</tbody>
</table>

© Copyright 1998-2013 CambridgeSoft Corporation, a subsidiary of PerkinElmer, Inc. All rights reserved.
<table>
<thead>
<tr>
<th>Move Down</th>
<th>Moves the selected items in the Columns to include in ChemDraw Excel File list down one step. The order of the columns in this list determines the order of the columns in the resulting ChemDraw Excel File.</th>
</tr>
</thead>
</table>

the resulting ChemDraw Excel File.
4. Working with Structures

4.1. About the Structure Viewer

The Structure Viewer is used to:

- View the structures marked in the visualization or to display structure search results.
- View, create, import, and export ID lists.

The key elements of the Structure Viewer are:

- Toolbar and lists drop-down
- List Content pane
- Structure Viewer pane
The following table describes the fields in the Structure Viewer window, as shown above.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar</td>
<td>Contains the buttons that allow you to export, import, rename and delete ID lists, and to edit list settings.</td>
</tr>
<tr>
<td>Lists</td>
<td>You can select an existing list in the Lists drop-down. The Structure Viewer maintains a dynamic list called Marked Rows that contains the marked rows in the active visualization. The number of items in each list is displayed within parentheses</td>
</tr>
</tbody>
</table>
4.2. Using the Structure Viewer

To navigate to the Structure Viewer:

1. Open data in Lead Discovery.
2. Click the Structure Viewer button in the toolbar.

Comment: You can also select View > Structure Viewer from the menu. The Configure Structure Connection dialog displays.

3. Select the columns in the visualization containing molecular structures and identifiers.
4. Click OK. The Structure Viewer displays.

Mark or highlight compounds in a visualization. When there are no marked rows, the structure from the currently highlighted row in the data table is displayed in the Structure Viewer pane of the Structure Viewer, and its identifier is displayed in the List Content pane. When there are marked rows, the structures from the marked rows are displayed in the Structure Viewer pane and their identifiers are displayed in the List Content pane. When you highlight a marked row, its corresponding identifier and structure will be highlighted in the Viewer and List Content panes.

Note: The Structure Viewer automatically becomes active when you perform a structure search.
4.3. About the Structure Viewer Toolbar

The image below shows the toolbar for the Structure Viewer.

![Structure Viewer Toolbar](image)

The following table explains the icons found on the Structure Viewer toolbar, as shown in the image above.

<table>
<thead>
<tr>
<th>Button / Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Import" /></td>
<td>Imports an ID list file to Structure Viewer.</td>
</tr>
<tr>
<td><img src="image" alt="Export" /></td>
<td>Exports the ID list currently selected in the Lists drop-down to an LST file.</td>
</tr>
<tr>
<td><img src="image" alt="Display ID" /></td>
<td>Displays the structures with the IDs from the active ID list in separate data table visualizations.</td>
</tr>
<tr>
<td><img src="image" alt="Data Table" /></td>
<td>Creates a new data table containing the structures and IDs from the current list. If additional data is available, it is included in the new table. Additional data may be drawn from the linked rows in the active data table or from an information link, depending on the source of the list.</td>
</tr>
<tr>
<td><img src="image" alt="Structure Connection" /></td>
<td>Opens the Structure Connection dialog where you can re-configure the mapping of ID and structure columns between data tables and Structure Viewer.</td>
</tr>
<tr>
<td><img src="image" alt="Manage Lists" /></td>
<td>Opens the Manage Lists dialog where you can change the name and description for previously created lists, as well as delete lists.</td>
</tr>
<tr>
<td><img src="image" alt="List Name" /></td>
<td>Displays the name of the selected list followed by the number of items in the list within parentheses. The elements of the selected list are displayed in the List Content and Viewer panes. Use this drop-down to select a different list.</td>
</tr>
</tbody>
</table>

4.4. About the Structure Viewer List Content Pane

In the List Content pane of the Structure Viewer, you can view the identifiers of the molecular structures from the ID list currently selected in the Lists drop-down. This can represent:

- The marked rows in the active data table.
A previously-created or imported ID list.
- The results of a structure search.

The List Content pane displays the identifiers of the rows in the list. The identifiers are taken from the column you selected as the ID column when the Structure Viewer was first opened. If the result of a structure query is shown, the metadata supplied by the information link are used.

<table>
<thead>
<tr>
<th>Right-click Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mark Selection in Active Visualization</td>
<td>Marks the rows with the selected IDs in the active visualization.</td>
</tr>
<tr>
<td>Create New List from Selection</td>
<td>Creates a new ID list from the IDs selected in the List Content pane.</td>
</tr>
<tr>
<td>Export Selection to SDFile</td>
<td>Opens the Export to SDFile dialog where you can export the selected IDs to an SDFile.</td>
</tr>
<tr>
<td>Export Selection to ChemDraw for Excel</td>
<td>Opens the Export to ChemDraw for Excel dialog where you can export the selected IDs to a ChemDraw for Excel file.</td>
</tr>
<tr>
<td>Copy IDs</td>
<td>Copies the selected IDs to the clipboard.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all IDs in the List Content pane.</td>
</tr>
<tr>
<td>Invert Selection</td>
<td>Inverts the selection in the List Content pane.</td>
</tr>
<tr>
<td>Remove IDs from List</td>
<td>Removes the selected IDs from the list in the List Content pane.</td>
</tr>
<tr>
<td>Manage Lists</td>
<td>Opens the Manage Lists dialog where you can change the names and descriptions of all previously added lists. You can also remove unwanted lists from Structure Viewer.</td>
</tr>
</tbody>
</table>

The right-click pop-up menu of the List Content pane contains a number of options. These options are explained in the table above.
4.5. About the Structure Viewer Structure Viewer Pane

In the Structure Viewer pane, you can see the structures of either the marked rows of the data table, or of the currently active ID list. This pane also displays the structures of the search results after you run a Structure Search.

The right-click context menu of the Structure Viewer pane contains a number of options. These options are explained in the table below:

<table>
<thead>
<tr>
<th>Right-click Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structure Search</td>
<td>Displays the Structure Search dialog.</td>
</tr>
</tbody>
</table>
| Copy                    | Copies information from the Structure Viewer to the Windows clipboard:  
  - **Structure** - Copies the selected structure as a structure which can be edited in the structure renderer.  
  - **Image** - Copies the selected structure as an image.  
  - **Image with All Visible Structures** - Copies the visible contents of the Structure Viewer pane as an image. |
| Renderer                | Use this option to select the default renderer used in the Structure Viewer pane (see Supported Renderers for more information). You can also change the renderer settings in the **Renderer Settings dialog**. |
| Print                   |  
  - **All** - When selected, specifies that all structures from the current list will be printed.  
  - **Visible Structures** - When selected, specifies that only those structures from the current list that are visible in the
4.6. Configuring Structure Connections

In the Configure Structure Connection dialog, you specify the columns of the table which will be treated by the Structure Viewer as the columns containing structures and IDs. The structure connection can be different for different lists.

To navigate to the structure connection dialog:

1. Click on the Structure Viewer button on the toolbar. The Configure Structure Connection dialog displays.
   Comment: You can also select View > Structure Viewer from the menu.
2. In Structure Viewer, you can also click on the Configure Structure Connection button, to open the dialog again.
The following table explains the fields found in the Configure Structure Connection dialog, as shown above.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID column</td>
<td>Select the column from the data table which you want to use as the identifier of the structure. The values from this column will be displayed in the List Contents pane of the Structure Viewer panel. Also, the Structure Viewer will use the IDs from this column for creating, exporting, and importing the ID lists.</td>
</tr>
<tr>
<td>Structure Column</td>
<td>Select a column that contains structures from those available in the active table visualization. The contents of this column will be rendered in the Structure Viewer pane. Displays the content type for the structure column. This field is read-only.</td>
</tr>
<tr>
<td>Link</td>
<td>Select an information link that contains structures from those available in the drop-down list. The structures from this link display in the Structure Viewer pane. The information links that are available here are configured using Information Designer. See the TIBCO Spotfire Lead Discovery - Installation Manual for more information.</td>
</tr>
</tbody>
</table>

5. Working with ID Lists

5.1. About ID Lists in the Structure Viewer

The ID lists in the Structure Viewer let you keep track of groups of compounds. Each time you conduct a structure search, the result is added as a new list in the List Content pane of the Structure Viewer. All the lists that you create are stored locally and appear in the Lists drop-down of the Structure Viewer.

The Structure Viewer also maintains a dynamic list called "Marked Rows", which contains the current set of marked rows. To save the results of a structure query or the set of marked rows more permanently, create a new list and convert the list to a data table, or export a list file or an SDFile.

To display the Structure Viewer:

1. Select Tools > Structure Viewer, or, click on the Structure Viewer button on the toolbar.

Comment: Another way to launch the Structure Viewer is to perform a structure search by right-clicking on a table column containing structures and selecting Structure Search. The Structure Viewer appears and the search results are displayed in the List Content and Structure Viewer panes.
The following table explains the actions you can perform from the Structure Viewer.

<table>
<thead>
<tr>
<th>Action</th>
<th>Instruction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a list</td>
<td>Do either one of: By default when you create a list, you can: (1) Perform a search using the <strong>Structure Search</strong> tool. Select the IDs in the current list, right-click and select <strong>Create New List from Selection</strong>.</td>
</tr>
<tr>
<td>Change list settings</td>
<td>Click the Manage Lists button, , on the Structure Viewer toolbar. You can also right-click and select <strong>Manage Lists</strong> from the pop-up menu. In the <strong>Manage Lists dialog</strong>, you can change the list name and description. In the <strong>Structure Connection dialog</strong>, reached from the Configure Structure Connection button, , you can re-map the ID and structure columns, if necessary.</td>
</tr>
<tr>
<td>Rename a list</td>
<td>Click the Manage Lists button, , on the Structure Viewer toolbar. You can also right-click and select <strong>Manage Lists</strong> from the pop-up menu. In the <strong>Manage Lists dialog</strong>, click to select the list you want to rename, then click Rename.</td>
</tr>
<tr>
<td>Export the list as an LST file</td>
<td>Select the list in the Lists drop-down and click the <strong>Export</strong> button, , on the Structure Viewer toolbar.</td>
</tr>
<tr>
<td>Import a list</td>
<td>Click the Import button, , on the Structure Viewer toolbar and select the list file to import in the Open File dialog.</td>
</tr>
<tr>
<td>Export selected IDs to an SDFile</td>
<td>Right-click on any of the selected IDs and select <strong>Export Selection to SDFile</strong> from the pop-up menu to open the Export to SDFile dialog.</td>
</tr>
<tr>
<td>Export selected IDs to a ChemDraw for Excel file</td>
<td>Right-click on any of the selected IDs and select <strong>Export Selection to ChemDraw for Excel</strong> from the pop-up menu to open the Export to ChemDraw for Excel dialog.</td>
</tr>
<tr>
<td>Display structure for a compound ID</td>
<td>Click on one or more identifiers in the List Content pane. The Structure Viewer pane will display the structures corresponding to the selected identifiers.</td>
</tr>
<tr>
<td>Create a new data table with the compounds from the current list</td>
<td>Select the list in the Lists drop-down and click the <strong>Create Table</strong> button, , on the Structure Viewer toolbar. A new data table will be created with the ID, structure, and any related data for the compounds in the list.</td>
</tr>
</tbody>
</table>
Mark compounds from the list
In the list, select the desired identifiers. Right-click and select **Mark Selection in Active Visualization**.

Copy a list
In the list, select the desired identifiers. Right-click and select **Copy IDs**.

Select all identifiers in a list
Right-click in the List Content pane and select **Select All**.

Invert the selection in the list
In the list, select the desired identifiers. Right-click and select **Invert Selection**.

Remove identifiers from the list
In the list, select the desired identifiers. Right-click and select **Remove IDs from List**.

### 5.2. About Manage Lists in the Structure Viewer

In the Manage Lists dialog, you can specify the list name and description of all available lists. See an image of the Manage Lists dialog below.

![Manage Lists dialog](image)

**To open to the Manage Lists dialog:**

1. Click the **Manage Lists** button, on the Structure Viewer toolbar or right-click in the **List Content** pane and select **Manage Lists**.
The following table explains the fields found in the Manage Lists dialog.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID Lists</td>
<td>Lists all currently available ID Lists in Structure Viewer.</td>
</tr>
<tr>
<td>Rename</td>
<td>Click on a list in the ID Lists pane and then click Rename to change the name of the selected list.</td>
</tr>
<tr>
<td>Delete</td>
<td>Click on a list in the ID Lists pane and then click Delete to remove the selected list from the Structure Viewer.</td>
</tr>
<tr>
<td>Description</td>
<td>Optional. Type a description of the contents of the selected list.</td>
</tr>
</tbody>
</table>

5.3. About New Lists Dialog

New lists are automatically created when you perform a structure search.

To create a new list from a selection in another list:

1. Ensure that the IDs are selected in the List Contents pane of the Structure Viewer. See Working with ID Lists for more information.

The following table describes the fields found in the New List dialog, as shown in the image above.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Type a suitable name for the new list.</td>
</tr>
<tr>
<td>Description</td>
<td>Optional. Type a description of the contents of the list.</td>
</tr>
</tbody>
</table>
6. Searching Structures

6.1. Searching for Compounds using Structure Search

The Structure Search tool allows you to perform substructure and similarity searches. See Details on Structure Search for more information regarding the individual search methods. The search returns a list of identifiers that is displayed in the Structure Viewer.

To search for compounds in a structure database:

1. In the Structure Viewer or in a table visualization with structures, click to activate the compound on which you want to base the search. The Structure Search dialog displays.
2. Right-click on the structure and select Structure Search from the pop-up menu.

Comment: You can also select Tools > Structure Search from the main menu.
3. Select one of the alternatives under Search for.

Comment: You can search for Substructure or Similarity.
4. If the Parameters button becomes available, click on it to edit the parameters available for the selected search method.

Comment: If you select Similarity search, you must enter a range of similarity values in the Similarity Search Parameters dialog. Similarity values range from 0 (least similar) to 100 (most similar).
5. If you want to import a structure from a file, click Import Structure. The Open File dialog appears. Select the file you want to import and click Open. The structure from the file will be displayed in the Structure Search dialog.
6. If required, click Edit. If more than one structure editor is available, you can choose which editor to use from a drop-down list. Your selected structure editor is launched. Edit the structure and click the button that returns the structure to Spotfire (in ChemDraw: OK, in Symyx® Draw (MDL): Transfer). Please refer to the documentation of your current structure editor for more details.
7. Select an information link in the Search in drop-down.

Comment: See Configuring Information Links in the Lead Discovery Installation Guide for more information about how to configure information links.
8. If required, limit the search to the current list of identifiers.

Comment: This option is only available when performing the search from the Structure Viewer and when any list except for the Marked Rows list is selected in the Lists drop-down of the Structure Viewer. When you start a structure search from table visualization without activating the Structure Viewer, or, if the Marked Rows list is selected, the Data Source option will be the only one available.
9. Specify the name for the resulting list.
10. Click OK. Structures in the database that match the search criteria are displayed in the Structure Viewer (Viewer pane). A new ID list is added and displayed in the List Content pane. To show the search results as a separate data table, select the search results list in the Lists drop-down and click the button on the Structure Viewer toolbar.
**Note:** Using Information Links, configured through the Information Designer, structures can be returned with the query molecule highlighted when performing a chemical substructure search as shown in the following example.

This capability is only available with the CSCartridge. Refer to the Lead Discovery Installation Guide for instructions on how to configure these information links.

### 6.2. About the Structure Search Dialog

To open the Structure Search dialog:

1. Select **Tools > Structure Search**, or right-click on a structure in a table, or the Structure Viewer and select **Structure Search** from the pop-up menu. The Structure Search dialog appears.
Note: Structures searches can also be performed in Lead Discovery without opening a file first (Tools > Structure Search). The following table explains the fields found in the Structure Search dialog, as shown in the image above.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search for Substructure</td>
<td>Performs a search for structures containing the specified substructure.</td>
</tr>
<tr>
<td>Similarity</td>
<td>Performs a search for structures similar to the specified master structure. Open the Similarity Search Parameters dialog and specify a range of values between 0 (least similar) and 100 (most similar).</td>
</tr>
<tr>
<td>Parameters</td>
<td>Launches the Parameters dialog where you can provide search parameters for similarity search.</td>
</tr>
<tr>
<td>Import Structure</td>
<td>Launches the Open dialog where you can select a structure file to use in the search.</td>
</tr>
<tr>
<td>Edit...</td>
<td>Launches your current structure editor where you can edit the structure before performing the search. The same thing is achieved by double-clicking the structure. If more than one structure editor is available, you can choose which editor to use from a drop-down list.</td>
</tr>
</tbody>
</table>
6.3. Viewing Structures in Virtual Columns

In the table visualization, you can view structures from remote data sources using virtual columns. You can connect to a virtual column and collect structure data from the remote data source both when showing structures in table visualization and when structures are shown in the Structure Viewer.

To add a virtual column:

1. Right-click on a table visualization and select Properties.
2. Select Virtual Columns and click Add > Structure Column.
3. In the Structure Column Settings dialog, select the key column, for example, the column that contains the IDs of the structures in your visualization.
4. Click Browse. The Open from Library dialog displays.
5. Select the information link that contains the data you want to retrieve in your virtual columns and click Open.

Note: Ensure the columns containing the key column data (in our example - structure IDs) and the data you would like to view in the virtual column (for example, molecular structures) are included in the information link.

6. Click OK. The virtual Structure column is displayed in the active table visualization.

6.4. Viewing Structures in Labels or Tooltips

You can display structures and other images in the labels or tooltips of visualizations.

To show structures from the loaded data in labels:

1. Open the Properties dialog for the visualization.
**Comment**: This is done by right-clicking on the visualization and selecting **Properties** from the pop-up menu.

2. Click on the **Labels** page in the list on the left. The Labels page displays.
   **Note**: Not all visualizations support labels.

3. Select the structure column under **Label By**.
   **Comment**: This is possible if the loaded data contains the structure information directly (e.g., if the loaded data is an SDF file). For example, select "Structure <MOLFILE>". If you want to retrieve the structures from an information link instead, see below.

4. Specify whether to **Show labels for: All** or **Marked rows**.
5. Ensure that **Get content from** is set to (Selected column).
6. Ensure that **Show as** is set to your current structure renderer. For example, Symyx® Draw (MDL).
7. If desired, change the Size of the structures using the slider.
8. Click **Close**.

### To show structures from an information link in labels:

1. Open the **Properties** dialog for the visualization.
   **Comment**: This is done by right-clicking on the visualization and selecting **Properties** from the pop-up menu.

2. Click on the **Labels** page in the list on the left. The Labels page displays.
   **Note**: Not all visualizations support labels.

3. Select an identifier column under **Label By**.
   **Comment**: Here you select the identifier column in your data table that will be used to match the identifier in the information link from which structures are to be retrieved.

4. Specify whether to **Show labels for: All** or **Marked rows**.
5. Select **Get content from**: **Structure Column**.
   **Comment**: This specifies that rather than displaying the information from the selected Label by column directly, the selected column will be used as an identifier when retrieving data from an information link.

6. Click on the **Settings** button next to **Get content from**. The Structure Column Settings dialog displays.

7. Ensure that the correct Key column is selected, and click **Browse**. The Open from Library dialog displays.

8. Click to select the information link containing your structures and click **Open**.
   **Note**: Ensure columns containing the key column data (in our example - structure IDs) and the data you would like to view in the virtual column (for example, molecular structures) are included in the information link.

9. Click **OK**.
10. Ensure that **Show as** is set to your current structure renderer. For example, Symyx® Draw (MDL).
11. Click **Close**.
To show structures from the loaded data in tooltips:

Most visualizations can display images from a binary image column, a shape file, or chemical structures in tooltips.

1. Open the Properties dialog for the visualization.
   Comment: This is done by right-clicking on the visualization and selecting Properties from the pop-up menu.
2. Click on the Tooltip page in the list on the left. The Tooltip page displays.
3. Click on Add. The Add Tooltip Value dialog displays.
4. Select the structure Column of interest.
5. Type a Name to display.
   Comment: This is the text shown together with the expression value in the tooltip, and also will be shown in the list of available tooltip values.
6. Ensure that Get content from is set to (Selected column).
   Comment: Make sure that Show as is set to your current structure renderer.
7. If desired, change the Size of the tooltip image by moving the slider.
8. Clear the Include value name in tooltip check box if you only want to display the image in the tooltip and not the name.
9. Click OK. The Add Tooltip Value dialog closes and the newly added value is shown in the Tooltip property page.
10. Click Close.

To show structures from an information link in tooltips:

1. Open the Properties dialog for the visualization.
   Comment: This is done by right-clicking on the visualization and selecting Properties from the pop-up menu.
2. Click on the Tooltip page in the list on the left. The Tooltip page displays.
3. Click Add. The Add Tooltip Value dialog displays.
4. Select an identifier Column.
   Comment: Here you select the identifier column in your data table used to match the identifier in the information link from which structures are to be retrieved.
5. Type a Name to display.
   Comment: This is the text that will be shown together with the expression value in the tooltip, and also will be shown in the list of available tooltip values.
   Comment: This specifies that rather than displaying the information from the selected Label by column directly, the selected column will be used as an identifier when retrieving data from an information link.
7. Click on the Settings button next to Get content from. The Structure Column Settings dialog displays.
8. Ensure the correct Key column is selected, click Browse. The Open from Library dialog displays.
9. Click to select the information link containing your structures and click Open.
   Note: Ensure sure that columns containing the key column data (in our example - structure IDs) and the data you would like to view in the virtual column (for example, molecular structures) are included in the information link.
10. Click OK.
11. Ensure that Show as is set to your current structure renderer.
12. If desired, change the Size of the tooltip image by moving the slider,
13. Clear the Include value name in tooltip check box if you only want to display the image in the tooltip and not the name.
14. Click OK. The Add Tooltip Value dialog closes and the newly added value is shown in the Tooltip property page.
15. Click Close.

7. Structure Filtering

7.1. About the Structure Filter

The Structure Filter is used to:

- Draw a chemical structure on which to filter the contents of a data table.
- Filter the contents based on full structure, substructure or similarity.

The key elements of the Structure Filter tool are:

- Toolbar
- Structure Filter pane
- Search Type drop down list

Chemical structures loaded into Spotfire in ChemDraw’s native file format (CDX) are supported in the Structure Filter provided ChemDraw is being used as the renderer and/or editor. The content is converted to MOLfiles or SMILES for renderers/editors that do not offer support.

7.2. Accessing the Structure Filter

To navigate to the Structure Filter:

1. Open data in Lead Discovery.
2. Click the Structure Filter button in the main toolbar.
3. The Structure Filter opens. By default, the Structure Filter opens above the Filters panel.
7.3. About the Structure Filter Toolbar

The image below shows the toolbar for the Structure Filter.

The following table explains the icons found on the Structure Filter toolbar, as shown in the image above.

<table>
<thead>
<tr>
<th>Button / Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Opens the Structure Editor to edit the current structure filter.</td>
</tr>
<tr>
<td></td>
<td>Clears the current filter.</td>
</tr>
<tr>
<td></td>
<td>Opens the Settings dialog for the selected renderer. Refer to Settings section.</td>
</tr>
<tr>
<td></td>
<td>Opens the Configure Structure Column dialog where you can identify the column containing the structure on which to perform the filter.</td>
</tr>
</tbody>
</table>

7.4. Search Types

The Structure Filter supports three structure search types:
There are three different means by which you can filter a data table based on chemical structure:

1. Using a structure editor, draw the chemical structure in the Structure Filter pane, and specify the search type. Alternatively, you can copy and paste it into the Structure Editor window.

2. Filter directly from the current table visualization by selecting a chemical structure within the table, and specify the search type.

3. Filter directly from the current scatter plot visualization by selecting a chemical structure within the scatter plot, and specify the search type. Each of these options is described below.

7.5. Performing a Structure Filter
A column named ‘Structure Match’ is added to the data table after filtering is performed. This column contains the tags ‘true’ and ‘false’. If the structure matches the defined filtering criteria, then it will be tagged as ‘true’; if not, it will be tagged as ‘false’.

This column appears at the bottom of the applicable data table on the Spotfire Filters panel. By default, the tags are set to display the matches (true). You can select to view the structures that do not match the filter criteria (false), or both (true and false).

**Monitoring Indexing and Filtering Progress**

Prior to filtering a data table for the first time, the structures undergo an indexing operation which may be time consuming depending on the number of structures. A progress bar is displayed indicating the indexing status.

Similarly when filtering a data table, a similar progress bar may be displayed.

In both cases, the Structure Filter panel is disabled.

**Note:** When loading a saved Spotfire analysis (*.dxp file) which contains a filter, the indexing and filtering will be performed upon loading.

**Filtering a Data Set with multiple structure columns**

If the data file contains more than one structure column, Lead Discovery will filter on the first column it detects containing structures.

You can change the selected Structure column on which to filter by clicking on the Configure source toolbar button.

![Configure Structure Column](image)

From here, you can specify the structure column on which to filter.

If there are no structure columns defined in a data table, the Structure Filter panel is disabled. However, if there are columns containing structure strings in the data table, opening the Structure Viewer will identify the structure column(s) by setting its content type property. At this point, the Structure Filter panel will be enabled.

**Filtering using the Structure Filter pane**

**To create a new filter:**

1. Open the Structure Filter.
2. Select the Filter Type from the drop down list. By default, Substructure is selected. If Similarity is selected, use the slider to specify the degree of similarity.

3. Double click in the Structure Filter pane to open the **Structure Editor**. By default, the ChemDraw Structure Editor opens.

![Structure Editor](image)

**Note:** To select a different Structure Editor, close the ChemDraw **Structure Editor**, and click on the Edit filter button in the toolbar. A list of available editors is presented. The selection is then saved as a user preference, and will be opened by default the next time you double click on the Structure Filter pane.

4. Draw the query structure in the **Structure Editor** window using appropriate tools.
You can also copy and paste a structure into the **Structure Editor** window. For example, a structure can be copied from the Structure Viewer, a table, or the Details-on-Demand panel, and paste it into the **Structure Editor**.

5. Click **OK** to initiate the filter.

**Filtering directly from a table visualization**

Structures can be rather large and complex to draw. Existing structures in the current visualization table can be selected as the filter structure.

**To filter directly from a table:**

1. Mark the row in the data table containing the structure on which to filter.

2. Right click on the row in the table visualization and select **Structure Filter**. Select the Filter Type (Full Structure, Sub-Structure, and Similarity).
If Similarity is selected as the Search Type, a 90% degree of similarity is used by default. You can adjust the degree of similarity (from 0 to 100%) using the slider in the Structure Filter panel. Each time the slider moves, the filter operation is triggered.

Note: Filtering can be performed on only one row at a time. If more than one row is marked, or no rows are marked at all, then the filtering search types will not be available for selection.

Filtering directly from a scatter plot

Existing structures in the current scatter plot visualization can be selected as the filter structure.

To filter directly from a scatter plot:

1. Mark the data point in the scatter plot representing the structure on which to filter.

2. Right click on the data point and select Structure Filter. Select the Filter Type (Full Structure, Sub-Structure, and Similarity).
If Similarity is selected as the Search Type, a 90% degree of similarity is used by default. You can adjust the degree of similarity (from 0 to 100%) using the slider in the Structure Filter panel. Each time the slider moves, the filter operation is triggered.

**Note:** Filtering can be performed on only one data point at a time. If more than one data point is marked, or no data points are marked, then the filtering search types will not be available for selection.

### 6.6. Editing a Filter

To edit a filter:

1. Click on the Edit filter button in the toolbar to open the Structure Editor. If applicable, select the editor to edit the current structure. Alternatively, you can also double click in the Structure pane to open the editor for the current structure.

2. Edit the query structure in the **Structure Editor** window using appropriate tools.

3. Click OK to initiate the filter.

**Note:** When editing a filter, all visualizations associated with the data table will be affected.

### 7.7. Clearing a Filter

To clear a filter:
1. Click on the Clear filter button in the toolbar. The current filter is cleared and the Structure Match column is removed from the data table.

**Note:** The filter applies to the data table, therefore clearing a filter will clear the results for all visualizations associated with the data table.

### 8. R-Group Decomposition

An R-Group decomposition analysis separates out the functional groups attached to a variable point of a specified substructure.

Following a substructure filter on a data table, you can perform an R-Group decomposition on the filtered data.

The resultant R-Group template structure is displayed in the Structure Filter panel. The functional group found at each Rn position is displayed in a virtual column which is added to the table visualization.

**Note:** You cannot perform an R-Group decomposition from a full structure or similarity search.

**To perform an R-Group Decomposition of a Data Table:**

1. Perform a Substructure filter on a data table.

2. From the Structure Filter panel, check the R-Group Decomposition checkbox.

A progress bar may be displayed indicating the analysis status. The Structure Filter panel is disabled during the analysis.

The resultant R-Group template structure is displayed in the Structure Filter panel, similar to the example shown below.
The decomposition results are displayed as virtual columns which are added to the table visualization. A new column is added for each of the R’s. The rows are populated with the R’s hits, similar to the example shown below.

The R-group fragments are rendered using the same renderer as the selected Structure column.
Note: After performing an R-Group analysis, you cannot edit the structure filter until you uncheck the R-Group decomposition checkbox. Alternatively, you can clear the filter.

Unchecking the R-Group Decomposition option removes the virtual columns from the data table visualization.

If you open a table visualization after performing the R-Group Decomposition, the virtual columns are not automatically added to the table visualization, and they will need to be added manually.

To add the virtual columns to a new table visualization:

1. Right-click on a table visualization and select Properties. You can also access the Table Properties by clicking on the Visualization Properties button in the main toolbar, or via the Edit > Visualization Properties menu item.

2. Select Virtual Columns and click on the Add button.


The virtual columns are now available to be added to the table visualization.

Note: If the ‘Add new columns automatically’ is set under Columns, the R-Group columns will have already been added to the table, and it is not necessary to continue with the remaining steps to add the columns to the visualization.

4. Select Columns. The virtual columns are listed under Available columns.
5. Use **Add >**, to select virtual columns to add to the table visualization.

6. Use **Move Up** and **Move Down** to specify the order of columns in the table visualization.

7. Click **Close**.

9. **Settings**

9.1. **Supported Renderers**

Lead Discovery modules provide support for several different renderers to display molecular structures. For more information see the system requirements for Lead Discovery at:


However, note that a few of the supported renderers can only be used to render structures in the table visualization, the Structure Viewer and the Structure Filter; they cannot be used to edit structures in the Structure Search tool. You can add one or more of these renderers to the list of default renderers, select any of them as default for a content type, and change the renderer settings.

**Note:** The default Renderer settings for each content type are honored in all rendering contexts. The settings defined for a default renderer are extended to the custom panels (e.g. Structure Viewer, Structure Filter).

If a default Renderer is not configured for a supported content type, ChemDraw is automatically selected, by default, as the renderer. **To add a renderer to the list of default renderers:**
1. Select **Tools > Options**.
2. Select the **Application** tab.
3. Click the **Renderer Setting** button.
4. Click **Add**. The Add Default Renderer dialog displays.
5. Specify the Content type and select the default renderer from the drop-down list in the dialog.
   **Comment**: You can only specify one default renderer per content type. See the table below for a description of content types.

### To change the default renderer for a certain content type:

1. Select **Tools > Options**.
2. Select the **Application** tab.
3. Click the **Renderer Settings** button.
4. Click to select the content type of interest and click **Edit**. The Edit Default Renderer dialog displays.
5. Select a new default renderer from the drop-down list.
   **Note**: The content type you enter can be an arbitrary string, but it is recommended that you use the MIME types defined for molfiles, CHIME strings, and SMILES strings as shown in the table below.

<table>
<thead>
<tr>
<th>Structure Format</th>
<th>Content Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>MDL molfile</td>
<td>chemical/x-mdl-molfile</td>
</tr>
<tr>
<td>MDL Chime string</td>
<td>chemical/x-mdl-chime</td>
</tr>
<tr>
<td>Daylight SMILES string</td>
<td>chemical/x-daylight-smiles</td>
</tr>
<tr>
<td>ChemDraw Chemical Structure Exchange</td>
<td>chemical/x-cdx</td>
</tr>
</tbody>
</table>

### To change the renderer and/or renderer settings for the structures displayed in the table visualization:

1. Right-click on a row in the table visualization and select **Properties > Columns**.
2. Select the column that contains chemical structures.
3. In the **Renderer** drop-down list, select the renderer to use.
4. Click the **Settings** button to change the renderer settings. The Renderer Settings dialog for the currently used renderer displays.
5. Change the renderer settings and click **OK**.

### To change the renderer used in Structure Viewer:

1. In the Structure Viewer pane of the Structure Viewer, right-click on the structure.
2. Select **Renderer**.
3. Select the renderer to use.

### To edit the renderer settings in the Structure Viewer:

1. In the Structure Viewer pane of the Structure Viewer, right-click on the structure.
2. Select **Renderer > Settings**. The Renderer Settings dialog for the currently used renderer displays.
3. Change the renderer settings and click **OK**.

**To change the renderer used in Structure Filter:**

1. In the Structure Filter toolbar, click on the Renderer settings button in the toolbar.
2. Select the renderer to use.

**To edit the renderer settings in the Structure Filter:**

1. In the Structure Filter toolbar, click on the Renderer settings button in the toolbar.
2. Select Settings. The Renderer Settings dialog for the currently selected renderer displays.
3. Change the renderer settings and click **OK**.

**Note:** When the renderer settings are changed in a custom panel (e.g. Structure Viewer, Structure Filter), they overwrite the default settings, and are saved with the .dxp file, however the settings are only applicable to that analysis.

### 9.2. Renderer Settings

The renderer is the program responsible for the display of structures in Structure Viewer, Structure Search, and Structure Filter and also when structures are shown in visualizations.

**ChemDraw Renderer Settings**

The ChemDraw renderer does not require you to select the format of the structure string. It auto-detects the data format.

CDX content in tables is displayed natively in the ChemDraw renderer.

You can select an existing ChemDraw Style Sheet file (.cds) for visualizing structures.

**To specify a template (.cds) file:**

1. From the ChemDraw Settings dialog, click on the **Load Settings** button.
2. From the drop down list box, select an existing .cds template file to apply to a structure visualization.
The selected .cds template file is displayed in the ChemDraw Settings dialog indicating that it was successfully loaded.

3. Click ‘OK’.

If you select ‘Default Settings’ from the drop down list, the factory settings are used.

Selecting ‘Other’ from the drop down list will open a Load Settings file browser from which you can browse for the .cds template.

Note: The settings for the ChemDraw Editor and Renderer are separate. The Editor settings are defined through the ChemDraw application (File menu). The Renderer settings are defined as described here. For example, if a template is loaded into the ChemDraw renderer, the Structure Filter panel will display an existing structure according to these settings. However, if the structure is edited using ChemDraw, although the structure is displayed in the editor using the same format as the renderer, any edits are displayed using the default ChemDraw editor template.
**Other Structure Renderers**

Other structure renderers auto detect the format to use for rendering, except if the data format is CHIME.

**Note:** Other structure renderers may display different type of settings, hence, the dialog you see may look different from the example shown here (Symyx® Draw (MDL) Settings).

The table below describes the fields in the Structure Renderer Settings dialog.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structure string</td>
<td>The structure string is auto detected with the exception of MDL CHIME. Activate the checkbox if the data format is CHIME. This checkbox is disabled if the renderer does not support the CHIME data format.</td>
</tr>
<tr>
<td>Show Hydrogens</td>
<td>Changes the hydrogen display settings. Possible options: For Symyx® Draw (MDL) - Off, Hetero, Terminal, HeteroOrTerminal, All For Accord - True, False For Marvin - Off, Hetero, HeteroOrTerminal, All</td>
</tr>
</tbody>
</table>
10. Glossary

Column
A vertical list of values in a data table

Column Name
The name of a column as displayed in the user interface. It is a normalized, trimmed, and unique text string. It is initially set to a tidied form of the external name, but it may be modified through a Rename Column operation.

Data Source
A handle to an external data source, for example, files or information links. A data source produces a single table of data.

Data Table
A data table in TIBCO Spotfire is defined as either data loaded from an external source, or new data created within the application. It has one or more columns and zero or more rows. A visualization is based on a single data table.

Data tables loaded from an external source can be linked or embedded. Linked data tables can be loaded completely into the application, but if the source is an information link they can also be configured to load data on demand only.

Data tables can be related to each other, using primary and/or foreign keys (key columns), but they can also be unrelated.

Details-on-Demand
The concept of expanding a small set of items to reveal more data behind it

DXP File
The file type used for analysis files created with TIBCO Spotfire. DXP files can be saved to disk and to the library. Defines what data to include and how to present it. Can include linked or embedded data based on user settings when saving the file, and includes one or more pages. There can only be one analysis file open at a time, but it is possible to run several instances of TIBCO Spotfire simultaneously, and one analysis file can also contain several data tables.

Filter
Filters are used to reduce the amount of data to work on in TIBCO Spotfire and are the same as Query Devices in TIBCO Spotfire DecisionSite. Filters can be either column filters, directly related to a column, or hierarchy filters (tree filters) which represent a hierarchy. Filters can be grouped into folders in the Filters panel.

ID column
A column in the table that contains structure identifiers
ID list
A list of structure identifiers

Information Link
Information links are predefined database queries, specifying the columns to be loaded, and any filters needed to reduce the size of the data table prior to visualization.

Library
The library is a space on the server where you can publish or open shared analysis files. Information links and the elements used to create information links are also stored in the library.

Marked Row
An item in a visualization becomes marked when you click on it, or, when it is captured using the rectangle method (left mouse button pressed while moving pointer). Marked rows are given a definable color to distinguish them from the rest of the data.

Marked Rows list
A dynamic list in the Structure Viewer called "Marked Rows" that contains the marked rows in the active visualization.

Marking
A marking identifies marked rows in the data tables of an analysis. If the data tables are related, the marked rows are propagated using the specified key relation between the data tables. Setting a marking in one data table does not affect the marking of unrelated data tables. Each analysis can hold multiple markings and each marking has its own marking color. One or more markings can be used to limit what data are displayed in a visualization.

Page
A page can be thought of as a "container" for visualizations, filters, a Details-on-Demand, etc. Pages make it possible to set up several sheets of visualizations that you can switch between in an analysis. Pages can contain visualizations and text areas that guide you through the analysis. Visualizations can only exist inside a page (they cannot be dragged outside even partly).

All visualizations in an analysis can be linked, both within and between pages, but they do not have to be. The visualizations on a page use one or more filtering schemes, and the filtering schemes determine whether visualizations are linked or not. The visualizations in a page can use one or several data tables.

Personalized Information Links
A personalized information link returns a subset of data depending on which user is logged in.

R-Group Decomposition
An R-Group decomposition analysis separates out the functional groups attached to a variable point of a specified substructure.
Row
A horizontal list of values in a data table

Structure Filter
The Structure Filter can be used to filter the contents of a data table based on chemical structure. The contents can be filtered based on full structure, substructure or similarity. Structure Viewer

The Structure Viewer can be used to display structures of the marked compounds in the visualizations. It can also be used to manage and view lists from various structure searches.

Structure Search
A tool used to search for compounds similar to or containing a specified master structure.

Table
A visualization with information arranged in rows and columns.

Table Column
A vertical list of values in a table

Table Column Header
An area used to identify a table column.

Table Row
A horizontal list of values in a table

Table Row Header
An area used to identify a table row.

URL
Uniform Resource Locator (A World Wide Web address)

Visualization
A visualization is a representation of some data in TIBCO Spotfire. For example, a table, a bar chart, a pie chart, etc. Visualizations display data from one data table. The data displayed can be limited by one or more filtering schemes and by zero, one or several markings. Visualizations show and allow modification to one marking.